Login to Secureframe failing for some customers
Incident Report for Secureframe
Resolved
We have resolved the issue
Posted Aug 31, 2022 - 05:24 PDT
Investigating
We have received reports of customers not being able to log in to Secureframe. We are investigating.
Posted Aug 31, 2022 - 05:16 PDT
This incident affected: Web Application.