Secureframe.com is erroring with status codes of 526

Incident Report for Secureframe

Resolved

The issue has been resolved.
Posted Jan 18, 2022 - 20:28 PST

Investigating

We are currently investigating this issue.
Posted Jan 18, 2022 - 19:50 PST
This incident affected: Marketing Website.