Planned System Maintenance and Upgrades
Incident Report for Secureframe
Resolved
We have completed maintenance
Posted Oct 09, 2022 - 20:50 PDT
Update
Maintenance is progressing successfully. We're re-enabling most functionality on the application.

The audit log page will continue to have degraded performance for the remainder of the maintenance.
Posted Oct 09, 2022 - 17:48 PDT
Monitoring
We're in the process of upgrading our services from 5:00 PM PDT - 8:00 PM PDT.
Posted Oct 09, 2022 - 17:00 PDT
This incident affected: Web Application and API.